A fix has been deployed and services are recovering.
Info dashboards, Meeting Room Displays, and other features reading on-premises Exchange calendars in the EU region are confirmed working again, and error rates have returned to normal.
Saving and updating Exchange connection credentials works again as well.
We will continue monitoring before marking this resolved.
Posted Sep 07, 2026 - 12:15 CEST
Identified
Rooms on Info dashboards and Meeting Room Displays may intermittently show an error ("ErrorUnauthorized") instead of meetings, and other features reading calendars through an on-premises Exchange connection can be intermittently affected, including saving or updating Exchange connection credentials.
Customers on Exchange Online (Microsoft 365) connections are not affected. Meeting data itself is intact — meetings, bookings, and orders are not lost.
Next update will come asap.
Posted Sep 07, 2026 - 12:06 CEST
This incident affected: Infrastructure (Europe) (Exchange Integration) and Infrastructure (North America) (Exchange Integration).