After monitoring the implemented solution, the issue related to the EWS connectivity and the degraded performance has been resolved, and the incident will now be closed.
Posted Dec 29, 2025 - 09:56 CET
Monitoring
We have identified a small set of customers affected by this issue. We have hardened our systems to handle the effect of unintentional misconfigurations, but load-based side effects can still occasionally affect other customers. We are monitoring the platform and will provide updates when additional actions are taken and/or the impact has subsided.
Posted Dec 23, 2025 - 21:13 CET
Investigating
We are seeing unstable connections to the Exchange Web Services integration that powers our add-ins and other services dealing with Exchange meetings directly. Currently, it seems to only affect EU customers, but we are investigating the extent and impact as well as the root cause, and will keep you updated.
Posted Dec 23, 2025 - 13:02 CET
This incident affected: Visitor Management (Europe) (Outlook Add-in), Meeting Services (Europe) (Outlook Add-in), and Room Booking (Europe) (Outlook Add-in).