Not able to open the Services Outlook Add-in if the service request is marked cancelled
Incident Report for AskCody
Resolved
After monitoring the performance of the released fix, there have been no instances of the "Unable to get property 'get' of undefined or null reference", nor have we identified any other adverse implications.

We, therefore, consider this incident resolved.
Posted Jul 29, 2022 - 09:11 CEST
Monitoring
Following the internal testing of a solution, we have now released the fix to the production environment, resolving the issue with the error "Unable to get property 'get' of undefined or null reference" that appears when the Services Add-in is opened, after the initial Service Request is cancelled.

We will monitor the performance of the fix before closing this incident.
Posted Jul 27, 2022 - 08:23 CEST
Update
Our development team has now found a fix to the issue, which is currently being tested internally. If the testing is successful, we will proceed to make the update available for our customers and actively monitor its performance.
Posted Jul 25, 2022 - 09:52 CEST
Update
Our Development Team continues to actively work to implement an optimal solution to prevent the "Unable to get property 'get' of undefined or null reference" from appearing, restoring the add-in functionality.

The current status of our Development Team's efforts is that they are testing various potential solutions in AskCody's Test Environment and monitoring the impact they have on the Outlook Add-in's performance.

As we progress with this testing, we will provide updates on this issue, based off their findings.
Posted Jul 20, 2022 - 13:08 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 15, 2022 - 08:54 CEST
Identified
We have identified an issue with the Services Outlook Add-in where the add-in opens with an exception "Unable to get property 'get' of undefined or null reference" if the request is marked cancelled. This also applies of only one of multiple requests is cancelled. The issue is identified and we are prioritizing finding a solution.
Posted Jul 14, 2022 - 14:29 CEST
This incident affected: Meeting Services (Europe) (Outlook Add-in) and Meeting Services (North America) (Outlook Add-in).