Degraded Performance - Resolved
Incident Report for The AskCody Platform
Resolved
Affected Users: Integrations Administrator and Owner Role Users
Region: All

After monitoring the implemented solution, the issue related to the Logs page in the Azure Active Directory Integration and the degraded performance on this component has been resolved, and the incident will now be closed.

Degraded Performance Definition: The affected component is working but is slow or otherwise impacted in a minor way. Does not affect downtime.
Posted Mar 24, 2023 - 09:47 CET
Monitoring
Affected Users: Integrations Administrator and Owner Role Users
Region: All

We have implemented a solution for the isse related with the Logs page in the Azure Active Directory Integration and are currently monitoring the performance.
When navigating to the Logs, you will no longer see an Error when accessing the page.

The next update will be provided once we have verified the fix is stable. This will happen no later than the 30th of March.

Degraded Performance Definition: The affected component is working but is slow or otherwise impacted in a minor way. Does not affect downtime.
Posted Mar 23, 2023 - 11:32 CET
Investigating
Affected Users: Integrations Administrator and Owner Role Users
Region: All

We are currently experiencing issues with the Logs page in the Azure Active Directory Integration, we are investigating the impact.
When navigating to the logs page, you will see an Error message like the following: Unterminated string in JSON at position 106512
Link to page: https://portal.onaskcody.com/admin/azure-ad-sync-log

This error message will prevent you from accessing the sync logs but will not impact the operation of the Azure AD Integration. Users and Hosts will continue to be synchronized.

The next update will be provided as we learn more about the issue, but by the 29th of March at the latest.

Degraded Performance Definition: The affected component is working but is slow or otherwise impacted in a minor way. Does not affect downtime.
Posted Mar 22, 2023 - 13:55 CET
This incident affected: Infrastructure (Europe) (Azure AD Integration) and Infrastructure (North America) (Azure AD integration).